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ABSTRACT 

 

Quantification of cells from immunostained images is a vital procedure in biomedical 

analysis, as it helps in the measurement of proliferation, immunodetection and differentiation 

of nuclear markers, which in turn play a significant role in the analysis of the cell functioning. 

Surgical pathology uses the quantified immunostained images as a diagnostic tool to 

differentiate between benign and tumor cells. However, manual quantification suffers 

numerous drawbacks, such as the lack of repeatability due to inter- and intra-observer 

variability, the lack of precision due to manual visual quantification and the larger time 

consumption for counting.  This led to the introduction of the computerized image counting 

techniques as a measure to overcome these difficulties.  

In this context, the present study proposes a software assisted GUI imaging technique 

and attempts to analyze its efficiency in the quantification of cells. The study adopted various 

analytical process, such as the comparison in the quantification between manual and automated 

in different stains, colocalization, to identify the number of active cells while images are 

spatially overlapped, fusion indexing and the comparison of the cell counts in myotubes with 

a control value. The comparative analysis between the proposed software assisted imaging 

technique and manual counting, using different stains, such as β-Gal, DAPI and sclerostin with 

the help of box plot, yielded a strong significant difference in DAPI and sclerostin stains. No 
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statistically significant differences were observed in β-Gal staining. The descriptive analysis 

in the quantification of overlapped cell using two overlapped images (β-Gal and DAPI) and 

three overlapped images (β-Gal, DAPI, sclerostin), demonstrated the improvement in the 

identification of active cells both in the case of two and three overlapped images. Furthermore, 

the comparative analysis of the fusion index value of Wnt3a images against control, using 

fusion bin range and fusion area methods, using box plot, revealed significant variation in  

fusion index value between Wnt3a and control in fusion area, whereas, the fusion bin did not 

yield any statistically significant outcome which help the study to reach into a conclusive 

inference. However, despite promising results, there is scope for improvement, which in turn 

opens the door for the future researchers to extend the study using more efficient automated 

imaging systems.  
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CHAPTER 1 

INTRODUCTION 

 

Background 

Immunostained image quantification is a vital procedure in the biomedical analysis as 

the quantification of proliferation, immunodetection, and differentiation of nuclear markers 

play a significant role in the study of cell functioning. The quantification of immunostaining 

helps to characterize the protein expression on normal or pathological slices of tissue. 

Further, this approach aids morphological controls and carries out detailed tissue and 

cell localization, which in turn avoids the problems caused by cell and tissue heterogeneity. 

This helps in the identification of nuclear markers that are useful for the prognostic and 

therapeutic purposes (Decaestecker et. al., 2009). Hence, one of the prime uses of 

quantification of immunostaining is in oncology where the data obtained from tumor samples 

may have therapeutic or analytical impacts (Elie, 2003). The surgical pathology uses the 

quantified immunostained images as a diagnostic tool to differentiate between benign and 

tumor cells (Matos et al., 2006). 

In the early ages, cell quantification was performed as a manual visual microscopic 

evaluation, which comprised of the assessment of ostensible density of immunostained cells 

for the assignment of the best representative category, through the investigator’s observation. 

However, the lack of repeatability due to inter- and intra-observer variability (Walker, 2006), 

and the lack of precision due to manual visual quantification (Benali et al., 2003) remained 

the major drawbacks that restricted the application of the methodology. The counting of cells 

fused with muscle cells is extremely difficult and time consuming. The time taken to 

manually calculate the count of stains in the case of fused ones is usually 20-40 minutes. 
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Even after this, it is difficult to get an accurate count, as the total number of stains for 

an image can be in hundreds. Hence, in order to overcome these difficulties, the 

computerized image counting techniques are introduced wherein numerous software are 

used. These techniques effectively reduce the impacts of observer biases and increase the 

throughput and sensitivity of immunohistochemistry (Pham et al., 2007). In addition, the 

studies of Lin et al. (1996) and Seidal et al. (2001) have highlighted the fact that software-

assisted immunostaining quantification has resulted in improved reproducibility and faster 

results. These results triggered other scholars, who conducted numerous researches and 

developed several software-assisted immunostaining quantification methods. 

 

Related Studies 

The shortcomings in the manual cell quantification motivated researchers to shift 

their focus to computer-assisted quantification tools, which were supposed to overcome the 

existing drawbacks. This resulted in the development of several automated methods with the 

help of software. Kohlberger et al. (1996) developed a true color RGB image analyzer on the 

basis of morphologically reduced instruction set computer processor. This analyzer was 

meant for estimating the area of stained endothelial cells and for comparing the percentage of 

factor VIII-related antigen-stained area with the counted micro-vessel density (CMVD) 

results. However, the tool could not overcome the drawbacks resulting in pixel dimension, 

which makes counting a difficult task and causes errors in the quantification of stained 

endothelial cells. Further, Lehr et al. (1997) designed a Photoshop-based image analysis tool 

by using commercially available and inexpensive software for the quantification of hormone 

receptor expression in breast cancer. The findings indicated the ability of the automated, 

software-supported imaging tool in the effective quantification of immunohistochemical 
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hormone receptor studies. However, the limited use of image databases was not enough to 

substantiate the tools’ applicability in the quantification of staining in large image databases. 

The quantification of immunostaining by the measurement of cumulative signal strength by 

using Photoshop software and MATLAB was performed by Matkowskyj, Schonfeld and 

Benya (2000). The study highlighted the inefficiency of the available techniques for counting 

the image pixels and pointed out the necessity of a specific software for the quantification. 

Veltri et al. (2000) proposed a novel image analysis on the basis of a bio marker called 

quantitative nuclear grade (QNG), which uses quantitative nuclear morphometry data, 

derived from computer-assisted imaging for cancer detection. Mofidi et al. (2003) designed a 

digital imaging system using Adobe Photoshop software for the assessment of oestrogen 

receptor status. Even though the findings indicated a fair assessment of oestrogen receptor 

positivity, the inadequate number of the targeted population restricted the magnitude of the 

results. In a similar kind of study, Nabi et al. (2004) used a computer-assisted imaging 

system to classify the immunostaining heterogeneity of androgen receptors in metastatic 

carcinoma of the prostate. The findings demonstrated the image analysis of androgen 

receptor immunostaining. The digital imaging approach yielded vital prognostic information, 

which in turn helped to predict the response to hormone treatment in patients with a 

metastatic carcinoma of the prostate. Despite the fairly good outcome, the study was 

skeptical about the applicability of the imaging system in a wider context and suggested 

further research before its usage. The increased use of immunohistochemistry (IHC) in 

clinical research triggered more studies and one such attempt was done by Fray et al. (2003) 

to standardize the IHC analysis. The authors proposed a novel imaging technique, which 

involved the conversion of brightfield images of diaminobenzidene (DAB)-labeled antigens 
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to normalized blue images, thereby allowing the automated quantification of positively 

stained tissues. However, the possible misclassifications in the quantification, during the 

usage of two or more chromogens with overlapping absorption spectra, cast shadows over the 

applicability of the tool. 

The importance of assessing androgen receptors in the detection of prostate cancer 

motivated Singh et al. (2005) to design an automated nuclear analysis tool using Java web 

start for the quantification of AR protein expression levels. However, the study failed to 

provide a satisfactory result regarding the performance of the proposed tool. Further, the 

quantification of protein expression levels was also performed by McCabe et al. (2005). The 

authors designed an automated imaging tool for the quantification. However, the study cast 

some doubts on the practical implication, due to the skepticism around the accuracy of the 

results. Decaestecker (2009) attempted to demonstrate the importance of proper imaging 

techniques in the quantification of immunostains on the tissue microarray materials. The 

study suggested certain pre-requisites for the imaging tool for the accurate quantification of 

immunostaining images. Diniz (2010) proposed a semi-automated computer-assisted image 

analysis for the quantification of immunostained receptors in vascular tissue sections. The 

findings of the study highlighted that the computer-assisted image analysis tools, meant for 

quantifying the immunostained receptors, must be specific to the applications. The 

importance of the quantification in the cancer detection process has widened its area of 

application and several researchers have attempted to propose different computer-assisted 

imaging tools for quantification. Following these, Sant’Anna, Sant’Anna and Parollini (2011) 

proposed an open-source image analysis software, called CellProfiler, to quantify the fibrosis 

induced in rats. CellProfiler permitted a simultaneous quantification of fibrosis in all of the 
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600 histological images, which were declared as malignant, at a rate of ∼ 10 s/image. 

However, the study failed to highlight the quantification ability of the tool. Another attempt 

in this route was made by Duran and Arriazu (2013), who proposed a metamorphic image 

analysis system for the quantification of protein expression in the immunoflurescene-stained 

sections. Even though the results indicated the ability of the image analysis tool to quantify 

the protein expressions, the study highlighted the necessity of certain prerequisites, such as 

the interpretation of images by skilled technicians, for an accurate quantification. The 

findings suggested that the application of the image analysis tool enabled the easy and 

accurate prediction of cancer. However, the major drawback of the method was that the tool 

required simultaneous immunostaining of all the sections to avoid the resistivity index (Ri) 

variability. 
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Research Gap 

Despite the advantages of the software-assisted immunostaining quantification, the 

applicability of the computer-based techniques is still limited due to the drawbacks 

highlighted in the comprehensive review conducted in the previous section. One of the prime 

shortcomings encountered by the review is the skepticism around the practical applicability 

of the imaging tool. Studies conducted by Nabi et al. (2003), McCabe et al. (2005), etc., have 

highlighted this shortcoming. The findings of the studies conducted by Lehr et al. (1997) and 

Mofidi et al. (2003) have highlighted the lack of sufficient data as a major drawback. 

The inability to yield comprehensive conclusions about the efficiency of the proposed 

tools is another drawback revealed by the review. The studies conducted by Singh et al. 

(2005) and Sant’Anna, Sant’Anna and Parollini (2011) have highlighted this drawback. 

The necessity of a specific software for quantification was highlighted by 

Matkowskyj, Schonfeld and Benya (2000) and Diniz (2010). The present study was 

significantly motivated by this necessity. 

The next potential shortcoming found by the review was the requirement of adequate 

pre-requisites, such as skilled technicians, for the interpretation of images. Several 

researchers, such as Decaestecker (2009) and Duran and Arriazu (2013), have argued that 

lack of adequate image interpretation skills restricts the applicability of the software. 

Furthermore, the difficulty in counting due to the pixel dimensions, (as pointed out by 

Kohlberger et al., 1996) and the possible misclassifications in quantification during the usage 

of two or more chromogens with overlapping absorption spectra (as indicated by Brey et al., 

2003) form the other drawbacks that were discovered by the review, which in effect worked 

as the motivation for the present study. 
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Objectives 

To develop an automated graphical user interface using MATLAB code for the 

quantification of cells from the immunostained images. 

 

Chapter Description 

The first chapter is the introduction chapter, which provides the overview of the 

research. The chapter contains the background of the study that briefs the requirement of 

quantification of immunostaining images and the reason behind the introduction of software-

assisted quantification techniques. The chapter also contains a review of the studies that 

propose or use different automated tools for quantification and emphasize on shortcomings in 

the existing software. Finally, the objectives of the current study are presented. 

The second chapter describes the software used for the development of automated 

Graphical User Interfaces (GUI). It explains about the toolbox used in MATLAB and also 

details the software design workflow and the steps taken in the development of the GUI. 

The third chapter describes the program modules presented in the automated process. 

The chapter outlines the step-by-step process for the analysis of immunostained images to 

count the cells. 

The fourth chapter illustrates the functioning of the entire analysis process through a 

step-by-step description and depicts the output presentation. 

The fifth chapter briefly describes the results of statistical analysis used to measure 

the efficiency of the automated GUI software. The chapter depicts the output of the 

comparative analysis between the manual and the automated GUI cell counts for various 

stained images. 

The sixth chapter concludes the study with a description of key inferences and the 
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final takeaway. The concluding chapter also shows the direction for future studies.  
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CHAPTER 2 

SOFTWARE DESCRIPTION 

 

Introduction to MATLAB® 

MATLAB® allows matrix manipulations, plotting of functions and data, execution of 

calculations, creation of user interfaces, and interfacing with projects written in different 

dialects, including C, C++, Java, Fortran and Python. The MATLAB® application is built by 

using the MATLAB® scripting language. The common usage of the MATLAB® application 

involves using the Command Window as an interactive mathematical shell or executing text 

files containing the MATLAB® code. 

Commonly, user interfaces (UIs) sit tight for a user to click a control button and 

respond to it. Every control and the UI itself, has one or more callbacks, named for the way 

they "get back to" to MATLAB® to request it to do things. A specific client activity, for 

example, squeezing a screen catch or ignoring the cursor a part, triggers the execution of 

every callback. The UI then reacts to these occasions. Several UIs have been developed in 

this thesis for various purposes. 

Graphical user interfaces (GUIs), otherwise called graphical client interfaces, give 

point-and-click control of programming applications, killing the need to take in a dialect or 

sort orders with a specific end goal to run the application. 

For more control over the configuration and advancement, one can write MATLAB® 

codes that characterize all part properties and practices. MATLAB® contains prebuilt codes to 

assist in the creation of the GUI for applications automatically. One can include dialog boxes, 

client interface controls, (for example, push catches and sliders), and compartments, (for 

example, boards and catch bunches). 
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Software Design Flow 

With the end goal to utilize this automated counting process, the client to tally the 

aggregate number of cells must adopt a careful methodology. There are seven fundamental 

parts of this product. They are: 

a. Queue 

b. File Loading 

c. Segmentation 

d. Thresholding 

e. Tools 

f. Results 

g. Help 

The parts are briefly described below. 

 

Queue 

Queue tab is one of the new tabs added to Immunostaining GUI. It has several 

functionalities. Each functionality is for a different type of image. The main advantage of 

queue tab is to process the image faster than the normal flow process. The queue process 

stops whenever it needs input from the user. 

 

File 

After loading the required image, the user can browse and select the image. When a 

new image is loaded, its width, height, color type, and bits per sample are shown and the 

name of the image can be changed and saved. 
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Segmentation 

Two actions are performed in this tab. The first action is choosing a channel from the 

four channels (Original, Red, Green, and Blue). The second action is to start the 

segmentation.  

 

Thresholding 

It is used as additional option to adjust the intensity of the stains. The low and high 

values can be manually entered in the box or can be done by dragging the bara. There are two 

types of thresholding. 

 

Tools 

Used to add some more criterion to the thresholded image and also to get count of 

stained cells. There are two types of functions under it. One for criterion another one is for 

counting. There are many types of criterions like, edge criterion, circularity criterion, Min 

and Maximum pixel area. In Cell counting there are box count, ROI count etc., 

 

Results 

Along with count of stains and thresholding values the results are stored in an Excel 

sheet. These are cached for further reference.  

 

Help 

Provide software usage tips. If users have any doubts on the flow while working, then 

such doubts are resolved by this functionality.  
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CHAPTER 3 

DESCRIPTION OF PROGRAM MODULES 

 

Queue 

β-Gal Queue 

β-Gal queue is to process β-Gal images to identify the total number of blue stains on 

the image. Normal image processing needs user to follow many steps to get results, 

remember the steps to process and it is time consuming but, with the help of β-Gal Queue 

process you can overcome the above problems. It stops only when it really needs human 

entered values. This module reduces the manual work by loading each image from the 

images folder and process it until all images are processed.  

This function load Images from selected folder, chooses the Original channel, asks 

user to manually segments the image, thresholds by using a double channel, calculates the 

minimum and maximum stain area, inter-cell distance, edge criterion, circularity criterion, 

calculates the total number of stains, and finally saves the results in a Microsoft Excel sheet. 

 

DAPI Queue 

DAPI queue is to process DAPI images to identify the total number of nuclei on the 

image. Normal image processing needs user to follow many steps to get results, remember 

the steps to process and it is time consuming but, with the help of DAPI Queue process you 

can overcome the above problems. It stops only when it really needs human entered values. 

This module reduces the manual work by loading each image from the images folder and 

process it until all images are processed. 
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This function loads the images folder, chooses the blue channel, uses the existing 

mask, thresholds by using a single channel, calculates the minimum and maximum stain area, 

inter-cell distance, edge criterion, circularity criterion, calculates the total number of stains, 

and finally saves the results in a Microsoft Excel sheet. Then the next image gets loaded and 

the above whole process is repeated. This process happens until, all the images in the folder 

are processed 

 

Non-Immune Queue 

It is to process non-immune images to identify the threshold value of non-immune 

images. Normal image processing needs user to follow many steps to get results, remember 

the steps to process and it is time consuming but, with the help of Non-Immune Queue 

process you can overcome the above problems. It stops only when it really needs human 

entered values. This module reduces the manual work by loading each image from the 

images folder and process it until all images are processed. 

Non-immune queue is to process non-immune images. This function loads the images 

folder, chooses the red channel, uses existing mask, thresholds by using a single channel, and 

finally save thresholded values in an excel sheet. Then the next image gets loaded and the 

above whole process is repeated. This process happens until, all the images in the folder are 

processed 

 

Sclerostin Queue 

It is to process Sclerostin images to identify the total number of nuclei on the 

sclerostin image. Normal image processing needs user to follow many steps to get results, 

remember the steps to process and it is time consuming but, with the help of Sclerostin- 
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queue process you can overcome the above problems. It stops only when it really needs 

human entered values. This module reduces the manual work by loading each image from the 

images folder and process it until all images are processed. 

This queue is to process Sclerostin images. This function loads the images folder, 

chooses the red channel, uses the existing mask, thresholds by using threshold value of non-

immune images in single channel, calculates the minimum and maximum stain area, inter-

cell distance, edge criterion, and circularity criterion, calculates the total number of stains, 

and finally saves the results in an Excel sheet. This process happens until, all the images in 

the folder are processed. 

 

Fusion Index Area Queue 

This queue is to process DAPI and Myotube images to get fusion Index value. i.e., 

ratio of total area of nuclei on the myotubes to the total area of nuclei on the whole image. 

Normal image processing needs user to follow many steps to get results, remember the steps 

to process and it is time consuming but, with the help of fusion index queue process you can 

overcome the above problems. It stops only when it really needs human entered values. This 

module reduces the manual work by loading each image from the images folder and process 

it until all images are processed. 

Fusion index area queue is to process the DAPI + Myotube images. This function 

loads the images folder, chooses the blue channel, and chooses the threshold by using a 

single channel and get total are of nuclei on myotube by using fusion index area. The fusion 

index area repeats the similar procedure for nuclei area on myotube images by calling a green 

channel, choosing the entire image, removing myotubes having less than three nuclei, 
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thresholding by using a single channel and saving the thresholded image. Finally, it loads the 

blue image, chooses the blue channel, uses the myotube mask, chooses a single channel 

threshold and fusion index area, and saves the results in an Excel sheet. This process happens 

until, all the images in the folder are processed. 

 

Fusion Index Bin Queue 

This queue is to process DAPI and Myotube images to get fusion Index value by 

using binning procedure. i.e., ratio of total number of nuclei on the myotubes to the total 

number of nuclei on the whole image. Normal image processing needs user to follow many 

steps to get results, remember the steps to process and it is time consuming but, with the help 

of fusion index queue process you can overcome the above problems. It stops only when it 

really needs human entered values. This module reduces the manual work by loading each 

image from the images folder and process it until all images are processed. 

This queue is to process DAPI/Myotube images. This function loads the images 

folder, chooses the blue channel, segments few smallest and biggest single and two fused 

nuclei which is helpful to get minimum, maximum and average size of the nuclei. To create 

myotube mask select the green channel and remove myotubes having less than three nuclei, 

thresholding by using a single channel, and saving the thresholded image. Finally, blue image 

is loaded, blue channel is chosen, existing mask is used, single channel threshold is chosen, 

fusion index with bin values are assigned and the results saved in an Excel sheet. The images 

are loaded only once, and the rest of the flow is same for all the images. 
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File 

 

Fusion Index Indicator 

The good feature of the immunostaining GUI software is that modules are 

independent of each other and can be reusable. There are few modules which should work 

slightly different for different images, so instead of rewriting whole module we have 

incorporated a few conditions on the exiting modules. Here Fusion index indicator notifies 

software that the current image is processed to get fusion index. It reduces the overwriting of 

the code. 

[The function is used to indicate the GUI software that the user is working with the 

fusion index images and all functions should work in such a way that they should aid in 

fulfilling the fusion index requirements] 

 

Upload an Image 

The immunostaining GUI is developed to process images. In order to process the 

image, it must first be uploaded into GUI. When this function is executed, a box opens to 

select the image present in the system. When an image is loaded into GUI, its various details 

like width, height, color type and bits per sample are also displayed in GUI. 

 

Reset All 

On pressing the reset button, all variables, mat files, and images of the previous 

image are deleted. If the previous data is present, then there are some chances of affecting the 

current image like taking the previous image data for the current image. After removing, an 
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information dialog box appears with a message to the user that all previous data is removed. 

 

Exit 

Exit callback closes all the GUI windows and removes the variables and mat files. 

The GUI can also be deleted by clicking the close button, but the previous image mat files 

will not be removed. Therefore, the exit function has more advantages over the close button. 

 

Segmentation 

Selection of a Color Channel 

Whenever an RBG image is loaded, it must be converted to binary image to perform a 

few MATLAB® operations. There are four channels in immunostaining GUI. They are 

original channel, blue channel, red channel, and green channel. 

Original channel: Changes image from RGB to HSV image 

Blue channel: It removes the blue color from the image and coverts into binary image 

Red Channel: It removes the blue color from the image and coverts into binary image  

Green Channel: It removes the blue color from the image and coverts into binary 

image 

Start Segmentation 

When the ‘start segmentation’ function is selected, it pops-up with a manual 

segmentation GUI. The user has many options to choose, out of which the fusion index 

requires only few options like push entire image, choose entire image, use the existing mask, 

select multiple regions, save the segmented image and exit. 

 

Choose Entire Image 
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This copies the entire image into a region where an image is to be segmented. The 

users can select the entire image for segmentation by using the ‘choose entire image’ 

function. When a user clicks this button, the entire image is copied into a region where an 

image needs to be segmented. 

 

Manual Segmentation 

ROI of an image is selected by drawing with free hand.  

 

Inner Segmentation 

Manually removing a part of an image by drawing with free hand 

 

Use Existing Mask 

Used to mask an image with another image, so that, the masked area gets selected as 

the segmented image. For example, the original blue image is masked with myotube shape 

after the segmentation and thresholding.  

 

Select Multiple Regions 

With the help of the ‘select multiple regions’ function, an image can be segmented 

multiple number of times at different places of the image. When this function is selected, a 

dialog box pops-up to select multiple regions of an image. After the user is done with a left 

click and a drag, another dialog box with the options of accept, more and undo pops-up. 

ACCEPT: If the user has finished by selecting multiple segments, then this button 

must be clicked to proceed further. 

MORE: If the user wants to do more segmentation, then this option takes him to do 
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one more round of segmentation. 

UNDO: If the user has selected different regions from the thought area, then this 

option helps him/her to correct his/her mistake. 

The dialog box pops-up after every round of segmentation. 

 

Create the Segmented Image Mask 

‘Create the segmented image mask’ is used if a user wants to create a mask of the 

segmented image. It is used when a user is working with myotube, because this mask is used 

for choosing a region from the blue image. 

 

Save the Segmented Image 

The user can use the segmented image in a further process, only when ‘save the 

segmented image’ function button is clicked. Whatever the image being segmented, it must 

be saved. 

 

Exit 

Users can come out of manual segmentation of GUIs by using the ‘exit’ function. 

This is the final button used in the manual segmentation. 

 

Thresholding 

The users can remove the unwanted noise and background from the image and 

highlight only the required stains. The thresholding function is an additional option found in 

the menu bar, which is used to adjust the intensity of the stains. The low and high values can 

be manually entered in the box or can be done by dragging the bar. 
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Single Channel 

The low and high intensity values are set to threshold the image. 

 

Double Channel 

The image is thresholded with hue saturation and threshold values. 

 

Tools 

 

Settings 

Minimum and Maximum Pixel Areas 

The minimum and maximum pixel areas are used to calculate the maximum, 

minimum and average of the thresholded image. When a function is selected by a user, a 

pop-up box appears with two buttons, single and double. The single button is used to 

calculate the average, minimum and maximum size of a single nuclei. The double button is to 

calculate the average, minimum and maximum size of a single nuclei. A single button needs 

to be selected when a single nucleus is segmented, and a double button needs to be selected 

when a two fused nucleus is segmented. There are two ways of using the maximum and 

minimum pixel areas. For images like β-Gal, DAPI, and Sclerostin, it gives information 

about the minimum and maximum areas of stains on the image and asks to manually enter in 

the dialog box for the removal of stains, less than the minimum value and more than the 

maximum value. 

Whereas, it gives information about the minimum, maximum and average of stains 

for both single stains and two fused stains for the fusion index images. If the stain area for 
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this image is less than 50 pixels, then that area is not considered as the minimum. 

 

Inter-Cell Distance 

The function is called to get distance between two selected points. A line is drawn 

between these two points to represent the distance. Sometimes, the single stain may be 

divided into two or more. In such a case, the broken stain should be considered as one and 

the function of ‘inter-cell distance’ comes into use. The distance between the broken stains is 

considered and that value is entered in a dialog box to make the software to consider the 

broken stains as one. 

 

Edge Criterion 

Edge criterion is to remove the stains on the edges of the manually segmented 

region. There are two types of manual segmentation, namely, outer manual segmentation and 

inner manual segmentation. The stains found on the edges of both segmented regions are 

removed. This function is required when the segmentation line touches stains, which should 

not be considered. 

 

Circularity Criterion 

Circularity criterion is added to remove the nuclei whose eccentricity value is less 

than .975ab. When the circularity criterion button is pressed, the stains with an eccentricity 

value of less than 0.975 are removed from the image. These stains are not considered as noise 

because they are the nuclei or cells that do not have an eccentricity value of less than 0.975. 

 

Cell Counts 
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The main aim of immunostaining GUI is to get the total number of stains on the 

image. Users can get a count of stains not only on the entire image, but also on free-hand 

regions of interest (ROI) and the selected box. 

 

Entire Area 

The function of ‘entire area’ is mostly used to count the total number of stains on the 

entire image. 

 

Draw a Free-Hand ROI 

Users can select their ROI by drawing with a free-hand. 

 

Draw a Box 

The ROI can be drawn in the form of a box. 

 

Manual Counting 

Counting an image with more than 500 stains is difficult without a marker because 

there might be a chance of counting the same stains a multiple number of times or a few of 

the nuclei may be skipped. The counting should be done with concentration because an 

interruption may result in a recount. However, it becomes easy with the help of a marker. 

Manual counting also works in the same way as a marker and an image. Once the user selects 

this function, a pop-up box appears with an instruction ‘left click to select pixel, double click 

or right click when completed’. Thus, users can select the stain by clicking the left button 

after the marking is done and indicate that the marking is done by clicking on the right 

button. The backspace button is to undo the marks. 
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Add and Remove 

Sometimes, the software does not recognize the stains that need to be considered and 

recognizes certain stains as noise. The ‘add and remove’ function is used for such stains. 

 

Fusion Index Bin 

Fusion index bin is the core function of the GUI. This function gives information like 

the minimum, maximum and average area of single and double nuclei and asks us to enter 

the bin range of the single and double nuclei with the information provided. Users must 

manually enter the bin range. The difference of the maximum single and double nuclei is 

added to the maximum double nuclei to get a triple fused nuclei maximum range and so on. 

The image is then displayed with the total number of nuclei count. Sometimes, a few nuclei 

may get skipped or may be counted more. Hence, a new method was incorporated to remove 

and add, respectively. Once the user is done with that, it gives a count of the nuclei and the 

fraction of the myotube over the blue nuclei. 

 

Fusion Index Area 

Since the area of individual nuclei is uniform, the total DAPI stained area generates a 

mask for what is a myotube and figures out what percentage of the DAPI-stained area is 

located within the myotube mask. This would still give an accurate measure of the fusion 

index (% nuclei located within myofibrils) without us having to know how many individual 

nuclei are present. 

 

Quantitative Output 
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The total area of myotubes (i.e., the sum of areas of all individual myotubes within an 

image), the average myotube area (i.e., the average area of individual myotubes), and the 

average number of nuclei per myotube constitute the quantitative outputs. In order to get 

these outputs, it is required that each myotube is traced as an individual object and an 

individual mask is made for each myotube. 

 

Results 

 

Co-Localization 

Co-localization is used to count the overlapped cells on two images (or three images). 

It joins images and count the overlapping cells. 

 

Two Images 

The two images are given here as the input to get the overlapped stains. 

 

Three Images 

The three images are given here as the input to get the overlapped stains. 

 

Save to Excel 

If the excel sheet is not created, then the program creates it and saves the results, such 

as date and time analysis (when it is copied into an excel sheet), single channel lower 

threshold level, single channel higher threshold level, single minimum pixel area, single 

maximum pixel area, double minimum pixel area, double maximum pixel area, number of 

nuclei in the manual count, total number of nuclei (blue), total number of nuclei (myotube 
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blue), fusion index fraction, comment, sum of areas, area 1, area 2,…area 20, etc. 

 

Help 

 

About 

About is the information about the persons involved in the development of the 

immunostaining of GUI. 

 

Content 

It is not always easy to go to the document present in the folders to refer to the flow 

while working on GUI. Most of the time, users just copy the software into any device and 

start working in that situation if they want to refer the flow available in the content. It has all 

the flow charts. Whenever users need the flow, they can refer to this flow chart and 

understand how to perform the task. Flowchart is a pictographic representation of workflow. 

It is a step-by-step process and each step is represented with a box. The boxes relate to 

arrows that represent the flow process. These flow charts give information to users about 

how the flow goes. The step name itself denotes what each step does. The flowcharts used in 

the immunostaining of GUI are a bit different from the original flowcharts. There are many 

types of boxes, with each one of them having its own meaning. 

Parallelogram box denotes processing 

Rectangular box denotes name for a group of similar functions Rhombus box denotes that a 

decision is necessary 

Flow lines denote the control that passes from and to Cloud box denotes the information to 

user 
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There is more than one flowchart for a process, such as fusion index bin and fusion 

index area. These flowcharts are just to make users understand the flow properly. There are 

many types of images with each having their own different flow. It is difficult for the user to 

remember all the flows accurately and if the user is new to immunostaining, then it would be 

difficult to know from where to start and end for obtaining the results. The flowcharts can be 

used in such situations. 

We have created flowcharts for five types of images, i.e., β-Gal, DAPI, Sclerostin, 

non-immune by normal process and non-immune by queueing images and calling functions. 

Fusion index images have four ways to process, namely, fusion index bin (normal and queue) 

and fusion index area (normal and queue). 

 

FAQ 

1. Which image among DAPI, Sclerostin, and β-Gal is better to process first? 

Answer: If you want to use the image mask of another image, it is better to work first on β-

Gal image, because this image has clear borders enabling proper segmentation. Its mask can 

be used for DAPI and Sclerostin. 

The borders of DAPI and Sclerostin images cannot be figured out properly when the channel 

is selected. 

 

2. What is the suggested saturation value for β-Gal images? 

Answer: The low saturation value for β-Gal images is 0.2 and the high saturation value is the 

default value. 

 

3. What is the suggested threshold value for β-Gal images? 



27 

 

Answer: The default value is the low threshold value and 0.65 is the high threshold value. 

 

4. What should be done, if the code is not working? 

Answer: Click on the reset button and start again. It will reset all the values to empty. 

 

5. When the code is run, should the folder be changed, or should the path be added? 

Answer: It is better to change the folder because all results are saved in the folder that 

contains the code. Otherwise, it can be saved in the documents folder. 
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β-Gal Normal Flowchart 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 3.1. β-Gal Normal Flowchart 
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β-Gal Queue Flowchart 

 

 

Figure 3.2. β-Gal Queue Flowchart 
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DAPI Normal Flowchart 

 

 

 

Figure 3.3. DAPI Normal Flowchart 
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DAPI Queue Flowchart 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 3.4. DAPI Queue Flowchart 
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Non-Immune Normal Flowchart 

 

 

Figure 3.5. Non-Immune Normal Flowchart 
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Non-Immune Queue Flowchart 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 3.6. Non-Immune Queue Flowchart 
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Sclerostin Normal Flowchart 

 

 

Figure 3.7. Sclerostin Normal Flowchart 
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Sclerostin Queue Flowchart 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 3.8. Sclerostin Queue Flowchart 
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Fusion Index Bin Normal Flowchart 

 

Figure 3.9. Fusion Index Bin Normal Flowchart – Blue Image 
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Figure 3.10. Fusion Index Bin Normal Flowchart – Green Image 

 

 

Figure 3.10. Fusion Index Bin Normal Flowchart – Green Image 
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Figure 3.11. Fusion Index Bin Normal Flowchart – Blue with Green Image 
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Fusion Index Bin Queue Flowchart 

 

 

Figure 3.12. Fusion Index Bin Queue Flowchart 
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Fusion Index Area Normal Flowchart 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 3.13. Fusion Index Area Normal Flowchart – Blue Image 
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Figure 3.14. Fusion Index Area Normal Flowchart – Green Image 
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Figure 3.15. Fusion Index Area Normal Flowchart – Blue with Green 
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Fusion Index Area Queue Flowchart 

 

 

Figure 3.16. Fusion Index Area Queue Flowchart 

  



44 

 

 

Manual Counting β-Gal with Segmentation Flowchart 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 3.17. Manual Counting β-Gal with Segmentation Flowchart 
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Manual Counting DAPI/Sclerostin with Segmentation Flowchart 

 

 

 

Figure 3.18. Manual Counting DAPI/Sclerostin with Segmentation Flowchart 
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Manual Counting β-Gal/DAPI/Sclerostin/Myotube without Segmentation Flowchar 

 

 

 

Figure 3.19. Manual Counting β-Gal/DAPI/Sclerostin/Myotube without Segmentation 

Flowchart 
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CHAPTER  4 

PROCEDURE WITH IMAGES 

β-Gal Procedure 

Step 1: Load Image File → Load an image 

 

Figure 4.1. β-Gal Procedure - Manual Load an image 

Step 2: Choose Channel 

Segmentation → Choose Channel → Original Image 
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Figure 4.2. β-Gal Procedure - Choose Channel 

Step 3: Segmentation 

Segmentation → Start segmentation → Manual Segmentation → Select Inner Region → 

Create the segmented Image mask → Save the segmented image → exit 

 

Figure 4.3. β-Gal Procedure – Start Segmentation 
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Figure 4.4. β-Gal Procedure – Segment Inner Outer region and create mask Step 

 

Step 4: Threshold 

Thresholding → Double Channel → Histogram Based1 

 

Figure 4.5. β-Gal Procedure – Select Double channel histogram 

Step 4.1: Set Saturation Value 

Change low saturation value around 0.15 to 2.5 based on image quality 
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Figure 4.6. β-Gal Procedure – Set saturation value  

Step 4.2: Threshold High value 

Change threshold high value to .45 to .65 to highlight nuclei 

 

Figure 4.7. β-Gal Procedure – Set threshold value 

 

Step 5: Save the Thresholded Image details 

Click to get the Threshold levels → Push to get the thresholded Image → Save 
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Figure 4.8. β-Gal Procedure – Save threshold image 

Step 6: Minimum and Maximum pixel removes stains less than minimum value and greater 

than maximum value 

Tools → Settings → Minimum and Maximum Pixel Areas 

 

 

Figure 4.9. β-Gal Procedure – Select Minimum and Maximum Pixel Areas 

The below images show smallest and biggest nuclei size in the image 
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Figure 4.10. β-Gal Procedure – Smallest and biggest Nuclei Information 

Below image shows stains less than 2 pixel 

 

 

Figure 4.11. β-Gal Procedure – Highlighted smallest Nuclei < 2 pixels 

 

Histogram Information 
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Figure 4.12. β-Gal Procedure – Histogram Information  

set the minimum and maximum value in the input box 

 

Figure 4.13. β-Gal Procedure – Minimum and maximum nuclei area selection 

 

Step 7: Inter cell distance remove split single nuclei 

Tools → Settings → Inter Cell Distance 
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Figure 4.14. β-Gal Procedure – Select Inter Cell Distance 

Figure 4.15. β-Gal Procedure – Calculate distance between two points 

 

 

Figure 4.16. β-Gal Procedure – Enter Inter cell distance box  
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Step 8: Edge Criterion removes edge stains from image 

Tools → Settings → Edge Criterion 

Figure 4.17. β-Gal Procedure – Select Edge Criterion 

 

Figure 4.18. β-Gal Procedure – Comparison between before and after edge criterion 

Step 9: Circularity Criterion removes stains which have eccentricity less than 0.975 

Tools → Settings → Circularity Criterion 
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Figure 4.19. β-Gal Procedure – Select Circulatory Criterion 

 

 

Figure 4.20. β-Gal Procedure – Comparison between before and after circulatory criterion 

 

Step 10: Calculates total number of stains on the image 

 Tools → Cell Counts → Entire Area 
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Figure 4.21. β-Gal Procedure – Select Entire Area cell count 

 

Figure 4.22. β-Gal Procedure – Total number of activated cells 

Step 11: Save details to excel sheet 

Results → Save to Excel 
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Figure 4.23. β-Gal Procedure – Select save to excel 

 

Figure 4.24. β-Gal Procedure – Comment box 

 

Figure 4.25. β-Gal Procedure – Record in excel sheet 

DAPI Procedure 

Step 1: load an image File → Load Image
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Figure 4.26. DAPI Procedure – Load an image 

 

Figure 4.27. DAPI Procedure – Loaded a DAPI image Step 2: Choose 

Channel 

Segmentation → Choose Channel → Blue Channel 
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Figure 4.28. DAPI Procedure – Choose blue channel 

 

Figure 4.29. DAPI Procedure – Blue image changed to black and white 

Step 3: Segment the Image 

Segmentation → Start Segmentation → Use Existing Mask → Save the Segmented Image → 

exit 
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Figure 4.30. DAPI Procedure – Choose start segmentation option 

 

Figure 4.31. DAPI Procedure – Segment image by using existing mask and save 

 

Step 4: Threshold Image by changing low and high threshold values but in most cases default 

value is sufficient 

Thresholding → Single Channel → Histogram Based 
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Figure 4.32. DAPI Procedure – Choose single channel histogram 

 

 

Figure 4.33. DAPI Procedure – Threshold the image with default values 

Step 5: Save thresholded image details 

Click to get the threshold levels → push to get the thresholded image → save 
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Figure 4.34. DAPI Procedure – Save thresholded image 

Step 6: Calculate Minimum and Maximum pixel areas 

Tools → Settings → minimum and maximum pixel areas 

 

 

Figure 4.35. DAPI Procedure – Select minimum and maximum pixel areas option 
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Figure 4.36. DAPI Procedure – Histogram Information 

 

Figure 4.37. DAPI Procedure – Cells minimum and maximum area information 

 

 

Figure 4.38. DAPI Procedure – Minimum and maximum area input box 
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Figure 4.39. DAPI Procedure – Image after processing Minimum and maximum pixel areas 

Step 7: Calculate Inter cell distance 

Tools → Settings → Intercell distance 

 

Figure 4.40. DAPI Procedure – Select Inter-cell distance option 
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Figure 4.41. DAPI Procedure – Calculated Inter cell distance 

 

Figure 4.42. DAPI Procedure – Enter inter-cell distance manually 

Step 8: Edge Criterion 
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Figure 4.43. DAPI Procedure – Image before edge criterion 

 

 

Figure 4.44. DAPI Procedure – Image after edge criterion  

Step 9: Removes stains whose eccentricity is less than 0.975 

Tools → Settings → Circularity Criterion 
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Figure 4.45. DAPI Procedure – Choose circularity criterion 

 

Figure 4.46. DAPI Procedure – Before and after circularity criterion  

Step 10: Calculates total number of stains 

Tools → Cell Counts → Entire Area 
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Figure 4.47. DAPI Procedure – Choose option to calculate entire area 

 

 

Figure 4.48. DAPI Procedure – Total number of activated calles image and count 

Step 11: Save results to Excel Sheet 

Results → Save to Excel 
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Figure 4.49. DAPI Procedure – Save results to excel 

 

Figure 4.50. DAPI Procedure – Comment box 

 

 

Figure 4.51. DAPI Procedure – Results in excel sheet 

Non-Immune Procedure  

Step 1: Load an Image File → Load Image 
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Figure 4.52. Non-Immune Procedure – Load an image 

Step 2: Choose Channel 

Segmentation → Choose Channel → Original Image 

Figure 4.53. Non-Immune Procedure – Choose original image channel 

Step 3: Segmented the image 

Segmentation → Start Segmentation → Manual Segmentation → Select Inner Region → 

save the Segmented Image → Exit 
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Figure 4.54. Non-Immune Procedure – Choose start segmentation option 

 

 

Figure 4.55. Non-Immune Procedure – Segment outer and inner region and save image 

 

Step 4: Threshold image 

Thresholding → Single Channel → Histogram Based 
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Figure 4.56. Non-Immune Procedure – Choose single channel histogram 

 

Figure 4.57. Non-Immune Procedure – Adjust low threshold value 
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Sclerostin Procedure 

 

Step 1: Load an Image File → Load Image 

Figure 4.58. Sclerostin Procedure – Load an image 

 

Figure 4.59. Sclerostin Procedure – Sclerostin Image  

Step 2: Choose Channel 

Segmentation → Choose channel → original Image 
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Figure 4.60. Sclerostin Procedure – Choose original image channel  

Step 3: Segmentation 

Segmentation → Start Segmentation → Use existing mask → Save the Segmented Image → 

Exit 

 

Figure 4.61. Sclerostin Procedure – start segmentation using mask and save image  

Step 4: Threshold of non-immune is used for sclerostin image 

Thresholding → Single Channel → Histogram based 
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Figure 4.62. Sclerostin Procedure – Choose single channel histogram 

 

Figure 4.63. Sclerostin Procedure – Set threshold value same as non-immune threshold value 

 

Step 5: Threshold the image details 

Click to get threshold levels → Push to get the thresholded images → Save 
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Figure 4.64. Sclerostin Procedure – Save threshold Image  

Step 6: calculate total number of stains 

Tools → Cell counts → Entire area 

 

Figure 4.65. Sclerostin Procedure – Calculate total number of cells 
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Figure 4.66. Sclerostin Procedure – Numbered cells on the image and its total 

 

Step 7: Save the results in excel sheet Results → Save to Excel 

 

Figure 4.67. Sclerostin Procedure – Save image details to excel sheet 
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Figure 4.68. Sclerostin Procedure – Comment box 

 

Figure 4.69. Sclerostin Procedure – Details in excel sheet 

 

Fusion Index Bin Procedure 

Step 1: Set Indicator 

 

From the File → Fusion Index Indicator. This is like an indicator just to know the 

program (Functions) that it is working on fusion Index. Because in Immunostaining each 

function performs many tasks based on the requirement. 

example: Min Max Pixel area Function 
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Figure 4.70. Fusion Index Bin Procedure – Set fusion index indicator  

Step 2: Load Image 

 

 

Figure 4.71. Fusion Index Bin Procedure – load fusion index image 
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Figure 4.72. Fusion Index Bin Procedure – loaded fusion index image 

Step 3: Choose Channel 

Segmentation → Choose Channel→ Blue Channel. 

It removes green (Myotube) from the image 

 

Figure 4.73. Fusion Index Bin Procedure – Choose blue channel to remove myotube 
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Figure 4.74. Fusion Index Bin Procedure – Changed blue image to black and white 

Step 4: Segmentation 

Segmentation → Start segmentation→ Choose Entire image → Select Multiple Regions 

Select few smallest and biggest single nuclei which is helpful to get minimum, maximum and 

average size of the nuclei 

Save→ Exit 

 

Figure 4.75. Fusion Index Bin Procedure – Select multiple single nuclei  
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 Step 5: Threshold Image 

Thresholding→ Single channel→ Histogram based 

This is to adjust the threshold value of the nuclei selected, it is better taking the default 

values.  

 

Figure 4.76. Fusion Index Bin Procedure – Select single channel histogram 

 

Figure 4.77. Fusion Index Bin Procedure – Set threshold value  
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Tools → Settings → Minimum Maximum Pixel Area → Single 

It gives information like maximum, minimum and average of the single nuclei in a window 

and graph (Histogram) form 

Step 6: Select single nuclei minimum, maximum and average values 

 

 

Figure 4.78. Fusion Index Bin Procedure – Calculate minimum maximum and average single 

nuclei area 
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Figure 4.79. Fusion Index Bin Procedure – Histogram Information 

 

Step 7: 

Repeat the same procedure for double nucle from start segmentation till min max pixel area 

but, in last step instead of selecting single tab select ‘double’ tab 

 

Figure 4.80. Fusion Index Bin Procedure – Select two fused nuclei  
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Step 8: Set Bin Range 

Tools → Cell Counts → Fusion Index Bin 

Select the bin range minimum, maximum and average of single and double nuclei based on 

the information displayed. 

 

Figure 4.81. Fusion Index Bin Procedure – Select fusion index cell count. 
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 Figure 4.82. Fusion Index Bin Procedure – Set minimum and maximum area of single and 

double nuclei 

Total number of nuclei in the pop-up box with numbering on the image 

 

Fusi Figure 4.83. Fusion Index Bin Procedure – Numbered nuclei on the image and its count 

You can reduce the nuclei count which are counted more than its number just by left click 



88 

 

once done right click. 

Can undo by pressing backspace 

 

Figure 4.84. Fusion Index Bin Procedure – Removing excess nuclei count 

You can increase the nuclei count which are counted less than its number just by left click 

once done right click. 

Can undo by pressing escape 

 

Figure 4.85. Fusion Index Bin Procedure – Add uncounted nuclei 
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Figure 4.86. Fusion Index Bin Procedure – Total number of added nuclei count  

Displays count of nuclei then choose Blue button from pop up window 

 

Figure 4.87. Fusion Index Bin Procedure – Choose the option blue 

 

Figure 4.88. Fusion Index Bin Procedure – Total number of nuclei after removal and addition 

for blue image 

Method to Process Myotube Images (Green) 

 Step 9: Load Image (same image) 
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Figure 4.89. Fusion Index Bin Procedure – load fusion index image 

 

Step 10: Segment myotubes 

Segmentation → Choose Channel → Green channel (instead of blue)  

 

Figure 4.90. Fusion Index Bin Procedure – Choose the green channel to highlight myotubes 
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Figure 4.91. Fusion Index Bin Procedure – Image after channel selection 

 

Segmentation→ Start Segmentation→ Choose Entire Image→ Select Multiple Regions 

After segmentation create the segmented Image Mask→ save the Segmented Image→ 

Exit 

Step 11: Segmenting Myotube 

Segmentation → start segmentation → Select Multiple region → save the segmented Image 

→ exit 
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Figure 4.92. Fusion Index Bin Procedure – select multiple region having more than three 

nuclei of myotubes 

Step 12: Threshold 

Thresholding → Single Channel → Histogram Based 

Change the threshold values until whole segmented image is red Save the thresholded image 

 

Figure 4.93. Fusion Index Bin Procedure – Threshold myotubes 
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BLUE + GREEN 

Step 13: Load an Image 

Load Image → Choose Channel → Blue Channel→ Segmentation → Start Segmentation→ 

Use Existing 

Choose the mask (Green Image Mask) → Save→ Exit 

 

Figure 4.94. Fusion Index Bin Procedure – Use myotube mask on DAPI image 

Step 14: Threshold Image 

Threshold→ Single channel→ Histogram Based 

Reduce the threshold so that it sizes matches with the original image nuclei size beside it 
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Figure 4.95. Fusion Index Bin Procedure – Threshold image after overlap 

Step 15: 

Tools → Cell Count→ Fusion Index Bin 

Select the bin range minimum, maximum and average of single and double nuclei based on 

the information displayed and Total number of Nuclei 

 

 

Figure 4.96. Fusion Index Bin Procedure – Total number of nuclei after using mask 
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Step 16: 

Tools → Cell Count→ Add or Remove 

 Reduce: You can reduce the nuclei count which are counted more than its number just by 

left click on the image once done right click. 

Can undo by pressing escape 

 

 

Figure 4.97. Fusion Index Bin Procedure – Reduce excess nuclei count 

Increase: You can increase the nuclei count which are counted less than its number just by 

left click on the image once done right click. 

Can undo by pressing escape 
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Figure 4.98. Fusion Index Bin Procedure – Add uncounted nuclei 

Select Myotube button from the pop-up window, which gives total number of nuclei count 

after manual removal and addition of nuclei count for Myotube  

 

Figure 4.99. Fusion Index Bin Procedure –Type of image indicator 

 

Figure 4.100. Fusion Index Bin Procedure – Total number of nuclei count 
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Figure 4.101. Fusion Index Bin Procedure – Fraction of fusion index 

 

Results→ Save to excel→ comment 

Step 17: Save results to excel sheet 

 

Figure 4.102. Fusion Index Bin Procedure – option to save details to excel 
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Figure 4.103. Fusion Index Bin Procedure – Comment box 

 

Records in excel sheet 

 

Figure 4.104. Fusion Index Bin Procedure – fusion index details in excel sheet 

 

Fusion Index Area Procedure 

Step 1: Set Indicator 

From the File → Fusion Index Indicator. This is like an indicator just to know the 

software modules that it is working for fusion Index.  
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Figure 4.105. Fusion Index Area Procedure – Set fusion index indicator 

Step 2: Load Image 

 

Figure 4.106. Fusion Index Area Procedure – load fusion index image 
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Figure 4.107. Fusion Index Area Procedure – loaded fusion index image 

Step 3: Choose Channel 

Segmentation → Choose Channel→ Blue Channel 

It removes green(myotubes) from the Image 

 

Figure 4.108. Fusion Index Area Procedure – Choose blue channel option for the image 
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Figure 4.109. 4.6 Fusion Index Area Procedure – Converted blue image to black and white 

image 

Step 4: Segmentation 

Segmentation → Start segmentation→ Choose Entire image → Select Multiple Regions 

Select few smallest and biggest single nuclei which is helpful to get minimum, maximum and 

average size of the nuclei 

Save→ Exit 
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Figure 4.110. Fusion Index Area Procedure – Choose segmentation option 

 

 

Figure 4.111. Fusion Index Area Procedure – save the whole image  

 

Step 5: Threhsold Image 

Thresholding→ Single channel→ Histogram based 

This is to adjust the threshold value of the nuclei selected it is better taking the default values 
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Figure 4.112. Fusion Index Area Procedure – Choose single channel histogram 

 

 

Figure 4.113. Fusion Index Area Procedure – threshold image 
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Figure 4.114. Fusion Index Area Procedure – Save thresholded image 

Step 6: Tools → Cell Counts→ Fusion Index Area 

 

 

Figure 4.115. Fusion Index Area Procedure – Choose fusion area cell count option 
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Figure 4.116. Fusion Index Area Procedure – Choose type of image processing Load Image 

 

 

Figure 4.117. Fusion Index Area Procedure – Load fusion index image 
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Figure 4.118. Fusion Index Area Procedure – Loaded fusion index image 

Step 10: Segment myotubes 

Segmentation → Choose Channel→ Green channel (instead of blue) 

 

 

Figure 4.119. Fusion Index Area Procedure – Choose green channel option 

Step 11: Segmenting Myotube 
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Segmentation → start segmentation → Select Multiple region → save the segmented Image 

→ exit 

 

Figure 4.120. Fusion Index Area Procedure – Change green image to black and white 

images 

 

Figure 4.121. Fusion Index Area Procedure – Choose start segmentation option 
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Figure 4.122. Fusion Index Area Procedure – Choose segmentation option 

 

 

Figure 4.123. Fusion Index Area Procedure – Remove unnecessary myotubes 

Step 12: Threshold 

Thresholding→ Single Channel→ Histogram Based 

Change the threshold values until whole segmented image is red 
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Figure 4.124. Fusion Index Area Procedure – Draw contour to remove myotubes 

 

Figure 4.125. Fusion Index Area Procedure – Before and after removed myotubes 
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Figure 4.126. Fusion Index Area Procedure – Choose segmentation option 

 

 

Figure 4.127. Fusion Index Area Procedure – Choose single channel histogram 
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Figure 4.128. Fusion Index Area Procedure – Threshold segmented image 

 

Figure 4.129. Fusion Index Area Procedure – Remove unwanted image 
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Figure 4.130. Fusion Index Area Procedure – Threshold unselected myotube 

 

 

Figure 4.131. Fusion Index Area Procedure – Save thresholded image 
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Figure 4.132. Fusion Index Area Procedure – Load fusion index image 

 

 

Figure 4.133. Fusion Index Area Procedure – Choose blue channel 
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Figure 4.134. Fusion Index Area Procedure – Image after channel selection 

 

 

Figure 4.135. Fusion Index Area Procedure – Select start segmentation option 
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Figure 4.136. Fusion Index Area Procedure – Use myotube mask on the DAPI image 

 

Figure 4.137. Fusion Index Area Procedure – Choose single channel histogram 
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Figure 4.138. Fusion Index Area Procedure – Threshold segmented option 

 

 

Figure 4.139. Fusion Index Area Procedure – Choose segmentation option 
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Figure 4.140. Fusion Index Area Procedure – Choose myotube option 

 

 

Figure 4.141. Fusion Index Area Procedure – Fusion Index value 

 

Co-localization 

Co-localization is used to count the overlapped cells in two or more images. It 

combines the images and then count the cells that are overlapping (sitting one over the other). 

We have implemented two types of co-localization 

i. Two images co-localization 

ii. Three images co-localization 

Following is the procedure to get Co-localized cell count for two images 

i. Two images co-localization  

Step 1: Load an image 

File → Load Image 
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Figure 4.142. Co-localization two images: – Choose to load an image option 

 

Figure 4.143. Co-localization two images – Loaded original image 

 

Step 2: Choose Channel 
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Segmentation → Choose Channel → Original Image 

Figure 4.144. Co-localization two images – Choose segmentation option 

Step 3: Segmentation 

Segmentation → Start Segmentation → Manual Segmentation → Select Inner Region → 

Create segmented Mask → Save results to Excel sheet → Exit 

 

Figure 4.145. Co-localization two images – Select start segmentation 
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Figure 4.146. Co-localization two images – Segment Inner and outer region 

 

Step 4: Threshold and save Image 

Click to get the threshold levels → push to get the thresholded image → save 

 

Figure 4.147. Co-localization two images – Threshold segmented image 

Step 5: Repeat the above procedure for another image 
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Figure 4.148. Co-localization two images – Thresholded DAPI image 

Step 6: Co-localization of two images 

Results → Colocalization → Two Images 

 

 

Figure 4.149. Co-localization two images – Choose segmentation option 
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Figure 4.150. Co-localization two images – Colocalization screen 

 

 

Figure 4.151. Co-localization two images – Option to choose first and second image 
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Figure 4.152. Co-localization two images – Image after overlapping 

 

 

 

Figure 4.153. Co-localization two images – Total number of overlapped cells 

Step 7: Save to Excel 

Results → save to Excel 
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Figure 4.154. Co-localization two images – Colocalization results in excel 

 

ii. Three images co-localization 

Step 1: Load an Image File –> Load Image 

 

Figure 4.155. Co-localization three images: – Choose to load an image option 
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Figure 4.156. Co-localization three images: – loaded original image  

Step 2: Choose Channel 

Segmentation → Choose Channel → Original Image 

 

 

Figure 4.157. Co-localization three images: – Choose original image channel 

Step 3: Segmentation 
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Segmentation → Start Segmentation → Manual segmentation → select the inner region → 

save the segmented image → Exit 

 

 

Figure 4.158. Co-localization three images: – Choose start segmentation option 

 

Figure 4.159. Co-localization three images – Segment inner and outer region of the image 

Step 4: Threshold and save Image 

Thresholding → Double Channel → Histogram Based1 
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Figure 4.160. Co-localization three images: – Choose double channel histogram 

 

 

Figure 4.161. Co-localization three images: – Save thresholed image 

Step 5: Repeat the above procedure for another two images 
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Figure 4.162. Co-localization three images: – Threshold DAPI image 

 

 

Figure 4.163. Co-localization three images – Thresholded sclerostin image  

Step 6: Co-localization of three images 

Results → Co-localization → Three Images 
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Figure 4.164. Co-localization three images: – Colocalization of three images screen 

 

 

Figure 4.165. Co-localization three images: – Image after co-localization 
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Figure 4.166. Co-localization three images: – Total number of activated cells 
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CHAPTER 5 

RESULTS 

 

Overview 

This chapter explains the findings and observations of the analysis of the images by 

using the automated GUI software. The study compared the results of the automated software 

with manual counting and attempts to demonstrate the efficiency of the proposed GUI 

software assisted image technique. Different types of stained images, such as β-

Galactosidase, DAPI and Sclerostin were used by the study for the analysis. The findings of 

the colocalization, which was performed to identify the number of active cells which had 

multiple staining modalities in the same cell, are also presented. The presentation of the 

findings of the fusion index using the GUI software and the comparison of the cell counts in 

the Myotube with a control value concludes the chapter. 

Excel sheet was used for the statistical analysis of the data. The study used Box plots 

to find out the significant difference existing between the manual and automated counting.  

 

Comparison between Manual and Software counting in different stains 

This section provides the comparative results of the cell counts (manual and software) 

in different stains. The study used box plot to illustrate the statistical differences between 

manual and software counting of cells in different image stains. The study used stains of β-

Galactosidase, DAPI and Sclerostin for the analysis and the results are presented. 

 

Difference between Software and Manual counting of cells in β-Gal 

Figure 5.1 provides the findings of the box plot, conducted to compare between the 
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outcomes of manual and software cell counting in the β-Gal stains. However, the box plot 

revealed no significant difference between the manual and software counting 

(p=0.906>0.05). Even though, the mean is marginally higher in the case of manual counting, 

it is not enough to yield any significant outcomes. Hence, the results indicated the fact that 

there is no significant impact is evident as a result of the use of software assisted cell 

quantification. The plot in Figure 5.1 depicts the graphical representation of the comparative 

results. 

 

 

Figure 5.1. Difference between Software and Manual counting of cells in β-Gal 

n.s. - No significant difference 

 

Difference between Software and Manual counting of cells in DAPI 

4′,6-diamidino-2-phenylindole (DAPI) is a blue-fluorescent DNA stain that is used to 

count the number of nuclei and to evaluate gross cell morphology (Tarnowski et.al.,1991). Its 

high affinity for DNA made it favorable for the counting of cells. Figure 5.2 yields the 

n.s 
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findings of the box plot, conducted to compare between the outcomes of manual and 

software cell counting in the DAPI stains. The findings indicated the fact that the cell count 

varied significantly between manual and software counting (p=0.00<0.05) and the 

quantification using software showed higher mean value 117.32 compared to the manual 

counting 101.97. Hence, this result clearly indicated the difference of the proposed software 

assisted quantification technique in comparison with manual counting. Figure 5.2 

demonstrates the differences in manual and software assisted cell counting. 

 

 

Figure 5.2. Difference between Software and Manual counting of cells in DAPI 

** p < 0.01 

Difference between Software and Manual counting of cells in Sclerostin 

Figure 5.3 shows the findings of the box plot, conducted to compare the outcomes of 

** 
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manual and software cell counting in the sclerostin stains. Sclerostin staining is widely used 

in fluorescence microscopy for the counting cells, especially bone cells, because the 

dysregulation of sclerostin expression highlights the pathophysiology of skeletal maladies 

indicated by loss of bone mass and the harmful effects of some cancers in the bone 

(Delegado,Satto and Bellido, 2017). An up-regulation of sclerostin stained cells can be an 

indicator of tumor (Zhu et al., 2017). The findings of the box plot demonstrated a clear and 

significant difference between manual and automated counting of stained cells(p=0.00<0.05). 

Figure 5.3 clearly highlighted the differences between the means of manual an automated 

counting, with automated counting yielded a significantly higher mean (72.21) compared to 

the manual counting (44.41). Hence, the findings exhibit the greater efficiency of the 

proposed software assisted quantification technique in comparison with manual counting. 

Figure 5.3 demonstrates the differences in manual and software assisted cell counting 

 

** 
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Figure 5.3. Difference between Software and Manual counting of cells in Sclerostin 

** p < 0.01 

 

Colocalization 

 

The counting of overlapped cells on two or three overlapped images is performed by 

Colocalization. The present study attempted to count the overlapped cells on both two 

overlapped images (β-Gal and DAPI) and three overlapped images (β-Gal, DAPI, Sclerostin) 

using the proposed software assisted technique and results are presented in this section. The 

study has performed a descriptive analysis to yield the range and mean of active cells 

presented in the overlapped images. Figure 5.4 provides the findings of the descriptive 

analysis to identify the ability of the proposed software assisted imaging technique in the 

quantification of active cells during the spatial overlapping of images. The findings regarding 

to the colocalization of the two images demonstrated the fact that the software assisted 

imaging system identified the active cells, which ranges from 0.00 to 15.00 with a mean of 

5±3 with respect to different images. Further, the analysis of three images indicated that the 

software identified the active cells with a mean of 0.6±0.7 and having the minimum count of 

0.00 and maximum count of 3.00. 

 

Summary about the samples and its measures 
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Figure 5.4 Box plot of Co-localization of two images 

 

Figure 5.5 Box plot of Co-localization of three images 

 

Fusion Index 

Fusion index is the percentage value of the ratio between the number of nuclei 

incorporated in the myotube and total number of nuclei in the field of view. In other words, 
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Fusion index = (number of nuclei incorporated in the myotube /total number of nuclei in the field of view) x 100. 

 

The present study, using GUI software, attempted to find out the fusion index value 

of Wnt3a images and compared it with the value of control cell. Wnt3a is a protein from the 

Wnt gene family, which enhances the signaling process and regulates the proliferation 

process (Shang et al.,2007). The study analyzed the fusion index across the fusion bin range 

and fusion area. The statistical tool box plot was used to find out the significant difference 

between the index values. The findings of these analyses are described in the following 

sections. 

Fusion Index Bin 

The fusion index bin will yield the information like minimum, maximum and average 

area of single and double nuclei. The findings of the box plot as indicated in the figure 5.5 

exhibited the fact that, albeit Wnt3a showed higher mean index value (0.67) compared to 

control index (0.59), the differences were not significant enough to reach into any conclusive 

inferences (p=0.18>0.05). Figure 5.6 shows differences between Wnt3a and control index 

values. 

 

Fusion index (bin range) 
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Figure 5.6. Differences between Wnt3a and control index values (bin range) 

n.s. – No Significant difference 

 

Fusion Index Area 

The fusion index area will yield the percentage of the DAPI stained area located 

within the myotube. This in effect will help to provide an accurate measure of the fusion 

without the information regarding the how many individual nuclei are present. 

The findings of the box plot analysis (as indicated in figure 5.6) indicated the fact that 

the index values are significantly varied between Wnt3a and control (p=0.002<0.005) with 

higher mean value exhibited by Wnt3a (0.66) compared to control (0.59). Figure 5.5 shows 

differences between Wnt3a and control index values. This result, in effect highlights the 

n.s 
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efficiency of the proposed software assisted imaging technique to yield significant results in 

the quantification of cells. 

Fusion index (area wise) 

 

Figure 5.7. Differences between Wnt3a and control index values (area wise) 

** p < 0.01 

 

  

** 
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CHAPTER 6  

CONCLUSION 

 

Overview 

Cell counting from immunostained images is a vital procedure in biomedical analysis 

as it helps in the quantification of proliferation, immunodetection, and differentiation of 

nuclear markers, which in turn have a significant role in analyzing the cell functioning. 

Hence, quantification of immunostained cells is largely used in oncology where the data 

obtained from tumor samples may have therapeutic or analytical impacts (Elie, 2003). 

Surgical pathology uses the quantified immunostained images as a diagnostic tool to 

differentiate between benign and tumor cells (Matos et al., 2006). Manual quantification has 

the drawbacks, such as the lack of repeatability due to inter- and intra-observer variability 

(Walker, 2006), the lack of precision due to manual visual quantification (Benali et al., 

2003), the larger time consumption taken for counting and the lack of accuracy. 

As a measure to overcome these difficulties, computerized image counting techniques 

was introduced. The studies of Lin et al. (1996) and Seidal et al. (2001) have highlighted the 

fact that software-assisted immunostaining quantification has resulted in improved 

reproducibility and faster results. In this context, the present study has proposed a software 

assisted GUI imaging technique and attempted to analyze its efficiency in the quantification 

of cells. The findings have been drawn on the basis of various analytical process, such as the 

comparison in the quantification between manual and automated in different stains, the 

colocalization, to identify the number of active cells while the image is spatially overlapped, 
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and the fusion indexing and the comparison of the cell counts in the Myotube with a control 

value. The significant outcomes drawn from these analyses are described in ‘findings’. 

  

Findings 

 The comparative analysis between the proposed software assisted imaging technique 

and manual counting in the quantification of stained cells, using different stains, such as β-

Gal, DAPI and Sclerostin with the help of box plot, yielded a strong significant difference in 

DAPI and Sclerostin stains by demonstrating the higher cell count as a result of the 

application of proposed software assisted imaging technique. However, with β-Gal the 

analysis could not reach into a significant conclusion regarding the efficiency of the proposed 

automated imaging system. 

 The descriptive analysis performed to analyze the efficiency of the proposed software 

imaging technique in the quantification of overlapped cell on both two overlapped images (β-

Gal and DAPI) and three overlapped images (β-Gal, DAPI, Sclerostin) demonstrated the fact 

in the case of two colocalized images, the software assisted imaging system identified the 

active cells, which ranges from 0.00 to 15.00 with a mean of 5±3 with respect to different 

images. However, the analysis of three images indicated that the software could only identify 

the active cells with a mean of 0.6±0.7 and having the minimum count of 0.00 and maximum 

count of 3.00. 

 The comparative analysis of the fusion index value of Wnt3a images against control, 

across the fusion bin range and fusion area using box plot, revealed significant variation in 

fusion index value between Wnt3a and control. Fusion area with higher mean value exhibited 

by Wnt3a (0.6±0.06) compared to control (0.5±0.04), whereas, despite showing higher mean 
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value for Wnt3a the fusion bin did not yield any proper significant outcome which help the 

study to reach into a conclusive inference. 

 

Future Directions 

Despite yielding the fairly good outcomes, the analysis depicted certain limitations 

that confined the scope of the study and in turn paved the way for the future studies. Albeit, 

the analysis highlighted the performance supremacy of the proposed automated imaging 

system in the quantification of the stained cells using DAPI and sclerostin stains, it could not 

repeat that vivid and favorable result in the case of β-Gal. Hence, the future researchers can 

extend this study using more efficient automated imaging systems which can yield a better 

and clear quantification results in β-Gal stain. The quantification of stained cells in the case 

of three colocalized images using the proposed imaging technique yielded less impressive 

results, which in turn opened the door for the future researchers to research and develop more 

advanced and refined technique which can yield higher counts from the three overlapped 

images. Finally, the researchers can also focus on developing a more powerful imaging 

technique, which can demonstrate a higher number of counts in the fusion bin. 
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